ATXMEGA: опыт использования USB модуля

Обсуждение использования Atmel микроконтроллеров.

ATXMEGA: опыт использования USB модуля

Сообщение protoder » 02 дек 2013, 17:45

Здравствуйте. Кто-нибудь пробовал работать с USB модулями микроконтроллеров ATXMEGA***AU? Я пока подключиться не сумел. Микроконтроллер ATXMEGA256A3U, AVR Studio 6. Пытался запустить демопроекты из LUFA и ASF. Разные. Для моего микроконтроллера примера не было, поэтому использовал для STK600 под ATXMEGA32A4U и ATXMEGA256A3BU, разумеется, поменяв в проекте тип контроллера и перекомпилировав. Результат везде один и тот же. Отрицательный. Компьютер фиксирует появление нового устройства в сети, однако сообщает, что устройство отключено, так как оно сообщило о неисправности (что-то типа этого).
Смотрел под отладчиком: USB_BUSEVENT_vect срабатывает несколько раз (suspend_event, resume_event, reset_event), после чего всякая активность прекращалась. USB_TRNCOMPL_vect не вызывался вообще ни разу.

То есть похоже, что USB сигнал не проходит вообще (проходил бы плохо, хотя бы прерывание с ошибкой появлялось бы, так ведь?). Скорее всего, это даже не нарушение тактировки ( какая-то тактировка есть по-любому, а при ее не соответствии стандарту мы по логике должны бы были получать ошибки), а просто отсутствие реакции на USB сигналы на выходах. То есть - USB модуль не работает вообще.

Буду признателен, если у кого-то будут идеи, в чем может быть проблема. И буду признателен вдвойне, если кто-то расскажет о своем удачном опыте.
protoder
У нас в гостях
У нас в гостях
 
Сообщения: 1
Зарегистрирован: 02 дек 2013, 17:41
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.


Вернуться в AVR (Atmel)

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot] и гости: 1